cPanel Version 88 and ClamAV

by | Jul 9, 2020

cPanel recently announced the latest version update v88 with a handful of features like MySQL 8 support. It is so nice to see the much-awaited MySQL 8 support in the test version, though they have updated their internal ClamAV package and it is started to conflict with ClamAV package that is installed into the Operation System.

This change is because they have started offering one one solution by default which needs ClamAV to function. We do not have more details but the update to v88 will be blocked if you have ClamAV is installed in your Operating System. This is going to affect so many scripts and software built on ClamAV integration and depending on the default ClamAV installation. Given below is the error that you may expect during v88 update.

Error: cpanel-clamav conflicts with clamav-0.102.2-4.el7.x86_64

Error: cpanel-clamav conflicts with clamav-lib-0.102.2-4.el7.x86_64

Error: cpanel-clamav conflicts with clamav-update-0.102.2-4.el7.x86_64

Error: cpanel-clamav conflicts with clamav-filesystem-0.102.2-4.el7.noarch

cPGuard is integrated to LibclamAV and thus need ClamAV packages to function. Since this change is inevitable, we are making updates in our code and from cPGuard version 3.20 we will use a different approach and comply with this change.

So if you have cPGuard version 3.20 installed on your server, you can safely uninstall ClamAV on your server and it will not affect cPGuard functioning as we will handle it internally during the health check. Please note that it will take a while to run the health check and fix it automatically,

If you need any clarification or if you have any questions, please contact support